PAT-A1008 Elevator 题目内容及题解

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意

模拟电梯,题目给出一个请求序列,求出某电梯完成所有请求所需要的时间。

解题思路

  1. 按照给定条件模拟电梯运行即可。

代码

#include<stdio.h>

int main(){
    int N;
    int i;
    int current=0,goal,time=0;
    scanf("%d",&N);
    for(i=0;i<N;i++){
        scanf("%d",&goal);
        while(current>goal){
            current--;
            time+=4;
        }
        while(current<goal){
            current++;
            time+=6;
        }
        time+=5;//wait 
    }
    printf("%d\n",time);
    return 0;
}

运行结果

PAT-A1008 Elevator 题目内容及题解