【Spark】Graphx开发环境搭建(Java)

查找需要的 jar 包

安装地址:https://mvnrepository.com/artifact/org.apache.spark/spark-graphx_2.11/2.4.0

其中,2.11 是 scala 的版本,2.4.0 是 spark 的版本。

在 eclipse 中导入 jar 包

【Spark】Graphx开发环境搭建(Java)

可能出现的问题

一开始下载的版本是 spark-graphx_2.12/2.4.0,而已经安装好的环境是 scala2.11 和 spark2.4.0,与已有的 spark 环境不匹配,报错信息如下:

Exception in thread “main” java.lang.NoSuchMethodError: scala.Product.$init$(Lscala/Product;)V

重新找到合适的 jar 包,下载后再导入到项目中:
【Spark】Graphx开发环境搭建(Java)