PAT (Advanced Level) Practice — 1136 A Delayed Palindrome (20 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805345732378624

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

:题意 将一个字符串与其本身的逆序串相加,判断得到的结果是否为回文串,如果不是,将结果再次与结果的逆序相加,再次判断是否为回文串,如果十步之后还没找到回文串,则输出 Not found in 10 iterations. 

:注意 输进来的字符本身就可能为回文串,直接输出即可。

#include<iostream>
#include<cmath>
#include<string>
#include <algorithm>
typedef long long ll;
using namespace std;
bool judge(string s){
	int len=s.length();
	for(int i=0;i<len;i++){
		if(s[len-1-i]!=s[i]){
			return 0;
		}
	}
	return 1;
}
int main(){
	string s;
	cin>>s;
	for(int i=0;i<10;i++){
		if(judge(s)){
			printf("%s is a palindromic number.\n",s.c_str());
			return 0;
		}
		int jw=0;
		string s1,ans;
		s1=s;
		int len=s.length();
		reverse(s1.begin(),s1.end()); 
		for(int i=len-1;i>=0;i--){
			ans+=(jw+(s[i]-'0')+(s1[i]-'0'))%10+'0';
			jw=(jw+(s[i]-'0')+(s1[i]-'0'))/10;
		}
		if(jw==1){
			ans+='1';
		}
		reverse(ans.begin(),ans.end());
		printf("%s + %s = %s\n",s.c_str(), s1.c_str(), ans.c_str());
		s=ans;		
	}
	if(judge(s)){
		printf("%s is a palindromic number.\n",s.c_str());
	}
    else{
    	printf("Not found in 10 iterations.\n");
	}
	return 0;
} 

PAT (Advanced Level) Practice — 1136 A Delayed Palindrome (20 分)