POJ2492 A Bug's Life

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

 

题意:就是找出是否有同性恋的虫子,

对于:

1 2

2 3

3 4

1 3

POJ2492 A Bug's Life

 

这是样例的运行过程

 

 

理解:

其实这就可以理解为如果与根节点是偶数那么就是同性  如果奇数那么就是异性

对于 ^  就是同性为0  异性为1;

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdio>
#include<algorithm>
int ca = 1;
const int N = 3000;
int p[N];
int cnt[N];
int findth(int x)
{
	if (x == p[x]) return x;
	else {
		int t = p[x];
		p[x] = findth(p[x]);
		cnt[x] = cnt[x] ^ cnt[t];//这个更新cnt的值,因为在并查集路径压缩会换父节点,所以也要更新
		return p[x];
	}
}
int flag = 0;
void unionn(int x, int y)
{
	int xx = findth(x);
	int yy = findth(y);
	if (xx == yy) {
		if (cnt[x] == cnt[y]) {
			flag = 1;
		}
		return;
	}
	p[xx] = yy;
	cnt[xx] = !(cnt[x] ^ cnt[y]);//这里异或取反 还有就是把这个值赋值给yy的子树的,因为刚开始赋值的都是0(cnt)
}
int main()
{
	int T;
	scanf("%d", &T);
	while (T--) {
		flag = 0;
		int n, m;
		scanf("%d %d", &n, &m);
		for (int i = 1;i <= n;i++) {
			p[i] = i;
			cnt[i] = 0;
		}
		while (m--) {
			int a, b;
			scanf("%d %d", &a, &b);
			unionn(a, b);
		}
		printf("Scenario #%d:\n", ca++);
		if (flag) printf("Suspicious bugs found!\n");
		else printf("No suspicious bugs found!\n");
		puts("");
	}
	return 0;
}