PAT-A1019 General Palindromic Number 题目内容及题解

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意

给定十进制数字和对应的进制数,检验该数字在对应进制下是否为回文数,并按照给定格式输出结果。

解题思路

  1. 进制转换;
  2. 检验是否回文,并按对应格式输出结果,并返回0值。

代码

#include<stdio.h>
void check(int a[],int num){
    int i,j;
    i=0;j=num-1;
    while(i<j){
        if(a[i]!=a[j]){
            printf("No\n");
            return;
        }
        i++;
        j--;
    }
    printf("Yes\n");
    return;
}

int main(){
    int i,N,b;
    int sum[50],num=0;
    scanf("%d%d",&N,&b);
    do{
        sum[num++]=N%b;
        N/=b;
    }while(N);
    check(sum,num); 
    while(num){
        printf("%d",sum[--num]);
        if(num==0){
            printf("\n");
        }else{
            printf(" ");
        }
    }
    return 0;
}

运行结果

PAT-A1019 General Palindromic Number 题目内容及题解