PAT TOP顶级 1027 Larry and Inversions (35 分)
题目描述:
1027 Larry and Inversions (35 分)
Larry just studied the algorithm to count number of inversions. He's very interested in it. He's considering another problem: Given a permutation of integers from 1 to n, how many inversions it has if we reverse one of its subarray?
Formally speaking, given an integer array a (indices are from 0 to n−1) which contains a permutation of integers from 1 to n, two elements a[i] and a[j] form an inversion if a[i]>a[j] and i<j. Your job is to count, for each pair of 0≤i≤j<n, the number of inversions if we reverse the subarray from a[i] to a[j].
Input Specification:
Each input file contains one test case. Each case consists of a positive integer n (≤1,000) in the first line, and a permutation of integers from 1 to n in the second line. The numbers in a line are separated by a single space.
Output Specification:
For each test case, output n(n+1)/2 integers in a single line. The results are for reversing subarray indicating by all possible pairs of indices 0≤i≤j<n in i-major order -- that is, the first n results are for the reverse of subarrary [0..0], [0..1], ...[0..n−1]; the next n−1 results are for the reverse of subarry [1..1], [1..2],..., [1..n−1] and so on.
All the numbers in a line must be separated by a single space, with no extra space at the beginning or the end of the line.
Sample Input:
3
2 1 3
Sample Output:
1 0 2 1 2 1
Hint:
The original array is { 2, 1, 3 }.
- Reversing subarray [0..0] makes { 2, 1, 3 } which has 1 inversion.
- Reversing subarray [0..1] makes { 1, 2, 3 } which has 0 inversion.
- Reversing subarray [0..2] makes { 3, 1, 2 } which has 2 inversions.
- Reversing subarray [1..1] makes { 2, 1, 3 } which has 1 inversion.
- Reversing subarray [1..2] makes { 2, 3, 1 } which has 2 inversions.
- Reversing subarrays [2..2] makes { 2, 1, 3 } which has 1 inversion.
暴力法,拿了20分,有没有同学可以改进的。。欢迎评论?
#include <iostream>
#include <algorithm>
#include <string.h>
#include <map>
using namespace std;
int cnt,n,flag;
vector <int> a,b;
int getni(vector <int>a){
for(int i=0;i<n-1;i++){
for(int j=i+1;j<n;j++){
if(a[i]>a[j]) cnt++;
}
}
return cnt;
}
void reverse(vector <int>&a,int i,int j){
while(i!=j){
int temp = a[i];
a[i]=a[j];
a[j]=temp;
i++;
if(i!=j) j--;
}
}
int main(){
cin>>n;
a.resize(n);
b.resize(n);
for(int i=0;i<n;i++){
cin>>a[i];
}
for(int i=0;i<n;i++){
if(!flag){
cout<<1;
flag =1;
} else cout<<" "<<1;
for(int j=i+1;j<n;j++){
b=a;
reverse(b,i,j);
cnt =0;
cout<<" "<<getni(b);
}
}
return 0;
}