POJ 2488 A Knight's Journey DFS(深度优先搜索)
A Knight's Journey
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 53688 | Accepted: 18228 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
题意解读:
国际象棋,从(1,1)开始走,看能否走完这个棋盘(大小为他给出的p和q),要求按字典序输出走的顺序。
分析:是求是否有解,DFS
难点:按字典序输出走的顺序
按上图顺序,就可以安字典序输出了,看好坐标轴的方向啊
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int map[26][26];
int a,b,d=1;
struct node{
int x,y;
}s[60];
int DFS(int dx,int dy,int f)
{
map[dx][dy]=1;
if(f==a*b)
{
printf("Scenario #%d:\n",d);
for(int i=0;i<f;i++)
{
printf("%c%d",(s[i].y+65),s[i].x+1);
}
printf("\n");
}
for(int i=0;i<8;i++)
{
int x1=dx+dir[i][0];
int y1=dy+dir[i][1];
if(f==a*b)
return 1;
if(x1<0||y1<0||x1>a-1||y1>b-1)
continue;
if(map[x1][y1]==0)
{
map[x1][y1]=1;
s[f].x=x1;
s[f].y=y1;
if(DFS(x1,y1,f+1))
{
return 1;
}
map[x1][y1]=0;
}
}
return 0;
}
int main()
{
int n,i,j;
scanf("%d",&n);
while(n--)
{
scanf("%d %d",&a,&b);
memset(map,0,sizeof(map));
if(DFS(0,0,1)==0)
{
printf("Scenario #%d:\nimpossible\n",d);
}
printf("\n");
d++;
}
return 0;
}