hdu1698---Just a Hook

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 

hdu1698---Just a Hook



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

 

Sample Input

1

10

2

1 5 2

5 9 3

 

Sample Output

Case 1: The total value of the hook is 24.

     这道题大意是经过几次区间修改后,再输出全部的和,这里的区间修改是将某个区间内的值都修改成某一个数,因为是区间修改需要利用lazy标记,与模板不太一样的地方就是这里是直接将值修改为一个数,而不是在原本的基础上相加。写pushdown()函数时需要注意更新子树时,左子树和右子树的区间范围(在这里被困住了好久,最终才发现是这里的区间范围不对,左子树是(len-(len/2)),右子树是len/2),还有就是最后输出部分的格式,为了保证格式正确,最好直接复制题目上的输出样例。

AC代码:

#include<cstdio>
#include<iostream>
using namespace std;
const int max_n=100005;
int a[4*max_n],sum[4*max_n];
int lazy[4*max_n];

void pushup(int id){
	sum[id]=sum[id*2]+sum[id*2+1];
}

void build(int L,int R,int id){
    lazy[id]=0;
	if(L==R){
        sum[id]=1;
        return ;
	}
	int mid=(L+R)/2;
	build(L,mid,id*2);
	build(mid+1,R,id*2+1);
	pushup(id);
}

void pushdown(int id,int len){
    if(lazy[id]){
        lazy[id*2]=lazy[id];
        lazy[id*2+1]=lazy[id];
        sum[id*2]=lazy[id]*(len-(len/2));  //只做修改
        sum[id*2+1]=lazy[id]*(len/2); //注意此处的范围
        lazy[id]=0;
    }
}

void update(int L,int R,int id,int l,int r,int v){
	if(l<=L&&r>=R){
        lazy[id]=v;
        sum[id]=v*(R-L+1); //只需要更改不需要在之前的基础上相加
        return ;
	}
	int mid=(L+R)/2;
	pushdown(id,R-L+1);
	if(l<=mid)
        update(L,mid,id*2,l,r,v);
    if(r>=mid+1)
        update(mid+1,R,id*2+1,l,r,v);
    pushup(id);
}

int main()
{
	int t,n,q,x,y,z,p=1;
	scanf("%d",&t);
	while(t--){
        scanf("%d",&n);
        scanf("%d",&q);
        build(1,n,1);
        while(q--){
            scanf("%d%d%d",&x,&y,&z);
            update(1,n,1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",p++,sum[1]);//这里可以直接输出sum【1】是因为要求的是整个区间的和
	}
	return 0;
}

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1698