HDU 2602 01背包
Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 88316 Accepted Submission(s): 36385
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
简单01背包
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000 + 10;
int val[maxn], vol[maxn], dp[maxn][maxn];
int main (){
int T, N, V;
scanf("%d",&T);
while (T--){
scanf("%d%d",&N, &V);
memset(dp,0,sizeof(dp));
for (int i = 1; i <= N; i++){
scanf("%d",&val[i]);
}
for (int i = 1; i <= N; i++){
scanf("%d",&vol[i]);
}
for (int i = 1; i <= N; i++){
for (int j = 0; j <= V; j++){
if (j < vol[i]){
dp[i][j] = dp[i - 1][j] ;
}
else dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - vol[i]] + val[i]);
}
}
// for (int i = 1; i <= N; i++){
// for (int j = 1; j <= V; j++){
// printf("%d ",dp[i][j]);
// }
// puts("");
// }
printf("%d\n",dp[N][V]);
}
return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std ;
const int Maxn = 1000 + 10 ;
int dp[Maxn] ;
int val[Maxn] ;
int vol[Maxn] ;
int main (){
int T;
int n, m ;
cin >> T ;
while (T--){
cin >> n >> m ;
for (int i = 1; i <= n; i++) cin >> val[i] ;
for (int i = 1; i <= n; i++) cin >> vol[i] ;
memset(dp, 0, sizeof(dp)) ;
for (int i = 1; i <= n; i++){
for (int j = m; j >= vol[i]; j--){
dp[j] = max(dp[j], dp[j - vol[i]] + val[i]) ;
}
}
cout << dp[m] << endl ;
}
return 0 ;
}
第一种是二维的写法,第二种对空间上进行了优化!