Number Steps
Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,… as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.
You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0…5000.
Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
Output
For each point in the input, write the number written at that point or write No Number if there is none.
Sample Input
3
4 2
6 6
3 4
Sample Output
6
12
No Number
分析:数学问题:
(0,0)------>0,(1,1)------->1
(2,0)------>2,(2,2)------->4
(3,1)------>3,(3,3)------->5
找规律!首先分x=y与y=x-2两种情况,然后再找其中的规律
#include <iostream>
#include <cstdio>
using namespace std;
void print(int a,int b)
{
if(a==b)
{
if(a%2==0)
printf("%d\n",a*2);
else
printf("%d\n",a*2-1);
}
else if(b==a-2)
{
if(a%2==0)
printf("%d\n",a*2-2);
else
printf("%d\n",a*2-3);
}
else
{
printf("No Number\n");
}
}
int main()
{
int n,a,b;
scanf("%d",&n);
while(n--)
{
scanf("%d %d",&a,&b);
print(a,b);
}
return 0;
}