PAT-A1115 Counting Nodes in a BST 题目内容及题解
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than or equal to the node's key.
- The right subtree of a node contains only nodes with keys greater than the node's key.
- Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.
Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:
n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
题目大意
题目给出一个二叉查找树的插入序列,要求按照格式要求输出按序列插入后的二叉查找树低两层的节点总数。
解题思路
- 建立二叉查找树的插入过程;
- 读取序列并依次插入;
- 前序遍历并记录每层的节点个数;
- 输出低两层的个数并按格式要求输出;
- 返回零值。
代码
#include<cstdio>
#define maxn 1010
int level[maxn],maxheight=-1;
struct Node{
int data;
Node *lchild,*rchild;
};
Node* Create(int v){
Node* root=new(Node);
root->data=v;
root->lchild=NULL;
root->rchild=NULL;
return root;
}
void Insert(Node* &root,int v){
if(root==NULL){
root=Create(v);
}else{
if(v>root->data){
Insert(root->rchild,v);
}else{
Insert(root->lchild,v);
}
}
return;
}
void PreOrder(Node* root,int depth){
if(root==NULL){
return;
}
level[depth]++;
if(depth>maxheight){
maxheight=depth;
}
PreOrder(root->lchild,depth+1);
PreOrder(root->rchild,depth+1);
}
int main(){
int N,a;
Node* root=NULL;
scanf("%d",&N);
while(N--){
scanf("%d",&a);
Insert(root,a);
}
PreOrder(root,0);
printf("%d + %d = %d\n",level[maxheight],level[maxheight-1],level[maxheight]+level[maxheight-1]);
return 0;
}
运行结果