PAT-A1105/B1050 Spiral Matrix/螺旋矩阵 题目内容及题解
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.
本题要求将给定的 N 个正整数按非递增的顺序,填入“螺旋矩阵”。所谓“螺旋矩阵”,是指从左上角第 1 个格子开始,按顺时针螺旋方向填充。要求矩阵的规模为 m 行 n 列,满足条件:m×n 等于 N;m≥n;且 m−n 取所有可能值中的最小值。
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^4. The numbers in a line are separated by spaces.
输入在第 1 行中给出一个正整数 N,第 2 行给出 N 个待填充的正整数。所有数字不超过 10^4,相邻数字以空格分隔。
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
输出螺旋矩阵。每行 n 个数字,共 m 行。相邻数字以 1 个空格分隔,行末不得有多余空格。
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
解题思路
- 读入待填入数据并计算方阵大小;
- 填充方阵边界;
- 模拟螺旋填数过程并标号;
- 输出结果并返回零值。
代码
#include<cstdio>
#include<cmath>
#include<algorithm>
#define maxn 10010
using namespace std;
struct Node{
int seq;
int vivid;
}G[maxn][maxn];
bool cmp(int a,int b){
return a>b;
}
int num[maxn];
int N;
int m,n;
void Init(){
int i;
scanf("%d",&N);
n=(int)sqrt(1.0*N);
for(i=0;i<N;i++){
scanf("%d",&num[i]);
}
sort(num,num+N,cmp);
while(1){
if(N%n==0){
m=N/n;
break;
}
n--;
}
for(i=0;i<=m;i++){
G[i][n].vivid=1;
}
for(i=0;i<=n;i++){
G[m][i].vivid=1;
}
}
void Op(){
int k=0;
int i=0,j=0;
while(k<N){
while(G[i][j].vivid==0){
//右移
G[i][j].vivid=1;
G[i][j].seq=k++;
j++;
};
//撞墙退出;
i++,j--;
while(G[i][j].vivid==0){
//下移
G[i][j].vivid=1;
G[i][j].seq=k++;
i++;
};
//撞墙退出
i--,j--;
while(j>=0&&G[i][j].vivid==0){
//左移
G[i][j].vivid=1;
G[i][j].seq=k++;
j--;
};
//撞墙或出界退出
i--,j++;
while(i>=0&&G[i][j].vivid==0){
//上移
G[i][j].vivid=1;
G[i][j].seq=k++;
i--;
};
//撞墙或出界退出
i++,j++;
}
}
void Print(){
int i,j;
for(i=0;i<m;i++){
for(j=0;j<n;j++){
printf("%d",num[G[i][j].seq]);
if(j<n-1){
printf(" ");
}else{
printf("\n");
}
}
}
}
int main(){
Init();
Op();
Print();
return 0;
}
运行结果