L1-8 估值一亿的AI核心代码 (20 分)
https://blog.****.net/qq_43700916/article/details/88927669
以上图片来自新浪微博。
本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
- 无论用户说什么,首先把对方说的话在一行中原样打印出来;
- 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
- 把原文中所有大写英文字母变成小写,除了
I
; - 把原文中所有独立的
can you
、could you
对应地换成I can
、I could
—— 这里“独立”是指被空格或标点符号分隔开的单词; - 把原文中所有独立的
I
和me
换成you
; - 把原文中所有的问号
?
换成惊叹号!
; - 在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI:
和一个空格。
输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n;
cin >> n;
getchar();
while (n--)
{
string s;
getline(cin, s);
//1)
cout << s << endl;
//2)
while (s[0] == ' ')s.erase(s.begin());
while (s[s.length() - 1] == ' ')s.erase(s.end() - 1);
for (int i = 0; i<s.length(); i++)
{
if (s[i] == ' ')
{
while (s[i + 1] == ' ')s.erase(s.begin() + i + 1);
if (s[i + 1]<'0' || s[i + 1]>'9'&&s[i + 1]<'A' || s[i + 1]>'Z'&&s[i + 1]<'a' || s[i + 1]>'z')
{
s.erase(s.begin() + i);
}
}
}
//3)
for (int i = 0; i<s.length(); i++)
{
if (s[i] >= 'A'&&s[i] <= 'Z'&&s[i] != 'I')s[i] -= 'A' - 'a';
}
//4)
for (int beg = 0;; beg++)
{
beg = s.find("can you", beg);
if (beg == -1)break;
if ((beg == 0 || s[beg - 1]<'0' || s[beg - 1]>'9'&&s[beg - 1]<'A' || s[beg - 1]>'Z'&&s[beg - 1]<'a' || s[beg - 1]>'z') && (beg + 7 == s.length() || s[beg + 7]<'0' || s[beg + 7]>'9'&&s[beg + 7]<'A' || s[beg + 7]>'Z'&&s[beg + 7]<'a' || s[beg + 7]>'z'))
{
s.replace(beg, 7, "A can");
}
}
for (int beg = 0;; beg++)
{
beg = s.find("could you", beg);
if (beg == -1)break;
if ((beg == 0 || s[beg - 1]<'0' || s[beg - 1]>'9'&&s[beg - 1]<'A' || s[beg - 1]>'Z'&&s[beg - 1]<'a' || s[beg - 1]>'z') && (beg + 9 == s.length() || s[beg + 9]<'0' || s[beg + 9]>'9'&&s[beg + 9]<'A' || s[beg + 9]>'Z'&&s[beg + 9]<'a' || s[beg + 9]>'z'))
{
s.replace(beg, 9, "A could");//由于后面还要处理'I'这里先用'A'代替'I',最后在变成'I'
}
}
//5)
for (int beg = 0;; beg++)
{
beg = s.find("I", beg);
if (beg == -1)break;
if ((beg == 0 || s[beg - 1]<'0' || s[beg - 1]>'9'&&s[beg - 1]<'A' || s[beg - 1]>'Z'&&s[beg - 1]<'a' || s[beg - 1]>'z') && (beg + 1 == s.length() || s[beg + 1]<'0' || s[beg + 1]>'9'&&s[beg + 1]<'A' || s[beg + 1]>'Z'&&s[beg + 1]<'a' || s[beg + 1]>'z'))
{
s.replace(beg, 1, "you");
}
}
for (int beg = 0;; beg++)
{
beg = s.find("me", beg);
if (beg == -1)break;
if ((beg == 0 || s[beg - 1]<'0' || s[beg - 1]>'9'&&s[beg - 1]<'A' || s[beg - 1]>'Z'&&s[beg - 1]<'a' || s[beg - 1]>'z') && (beg + 2 == s.length() || s[beg + 2]<'0' || s[beg + 2]>'9'&&s[beg + 2]<'A' || s[beg + 2]>'Z'&&s[beg + 2]<'a' || s[beg + 2]>'z'))
{
s.replace(beg, 2, "you");
}
}
//6)
for (int i = 0; i<s.length(); i++)
{
if (s[i] == '?')s[i] = '!';
if (s[i] == 'A')s[i] = 'I';
}
//7)
cout << "AI: " << s << endl;
}
return 0;
}