HDU1695(GCD)莫比乌斯入门题
GCDTime Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 18162 Accepted Submission(s): 6995 Problem Description Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs. Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases. Output For each test case, print the number of choices. Use the format in the example. Sample Input 2 1 3 1 5 1 1 11014 1 14409 9 Sample Output Case 1: 9 Case 2: 736427 Hint For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
|
学习莫比乌斯的一道经典入门题,笔记如下:
AC代码:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
ll a,b,c,d,k,e;
int tot=0;
ll miu[maxn],prime[maxn];
bool isPrime[maxn];
void getmiu(){
memset(isPrime,1,sizeof(isPrime));
miu[1]=1;
for(ll i=2;i<=maxn;i++){
if(isPrime[i]) prime[++tot]=i,miu[i]=-1;
for(ll j=1;j<=tot;j++){
if(i*prime[j]>maxn) break;
isPrime[i*prime[j]]=false;
if(i%prime[j]==0){
miu[i*prime[j]]=0;//????
break;
}else miu[i*prime[j]]=-1*miu[i];
}
}
}
int main()
{
getmiu();
int t;
cin>>t;
int cas=0;
while(t--)
{
cin>>a>>b>>c>>d>>e;
if(e==0)
{
printf("Case %d: 0\n",++cas);
continue;
}
ll ans1=0,ans2=0;
b/=e; d/=e;
k=min(b,d);
for(ll i=1;i<=k;i++)
{
ans1+=miu[i]*(b/i)*(d/i);
ans2+=miu[i]*(k/i)*(k/i);
}
printf("Case %d: %lld\n",++cas,ans1-ans2/2);
}
}