POJ - 2018 Best Cow Fences (二分 长度>=l的子序列最大和+前缀和)
Best Cow Fences
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 14467 | Accepted: 4664 |
Description
Farmer John's farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.
FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.
Calculate the fence placement that maximizes the average, given the constraint.
Input
* Line 1: Two space-separated integers, N and F.
* Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
Output
* Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.
Sample Input
10 6
6
4
2
10
3
8
5
9
4
1
Sample Output
6500
Source
书上讲得完美
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std ;
const int N=100005;
const double eps=1e-5;
double a[N],b[N],sum[N];
int n;
double max_sum_L(double mid,int m)
{
for(int i=1;i<=n;i++)
b[i]=a[i]-mid;
for(int i=1;i<=n;i++)
sum[i]=sum[i-1]+b[i];//求前缀和,
double ans=-1e10;
double minn=1e10;
for(int i=m;i<=n;i++)
{
minn=min(minn,sum[i-m]); ///维护左端最小值
ans=max(ans,sum[i]-minn); ///维护长度>=的子序列的最大值
}
return ans;
}
int main()
{
int m;
scanf("%d%d",&n,&m);
double minn=1e10;
double maxx=-1e10;
for(int i=1;i<=n;i++)
{
scanf("%lf",&a[i]);
minn=min(a[i],minn);
maxx=max(a[i],maxx);
}
double l=minn;
double r=maxx;
while(r-l>eps)
{
double mid=(l+r)/2;
if(max_sum_L(mid,m)>=0)
l=mid;
else
r=mid;
}
cout<<int(r*1000)<<endl;
return 0 ;
}