NYOJ 287 Rader ( 区间选点问题)(有图解)
Radar
时间限制:1000 ms | 内存限制:65535 KB
难度:3
- 描述
-
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
- 输入
- The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros - 输出
- For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
- 样例输入
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
- 样例输出
Case 1: 2 Case 2: 1
- 来源
AC代码:
//这道题应该抽象为P1 P2 P3 。。。向X轴发射半径为r的波,例如P1为圆心画圆与X轴相交的两点之间便是雷达想要扫描到P1的活动范围,那么P2,P3。。。以此类推,它们与X轴分别相交的线段区间的公共区域,便是雷达想要同时扫描到它们时,雷达应该在的区域,就像线段竖向排,每次画一条竖线穿过能穿过的线段,画几条能将线段全部穿过,如下图示意:
//即区间选点问题: 数轴上有n个闭区间。取尽量少的点,使得每个区间内都至少有一个点。
//注意:变量要设成浮点型,并且雷达只会在X轴上移动
#include <stdio.h>
#include <math.h>#include <algorithm>
using namespace std;
struct node
{
double l,r; //要设成double型,否则会精度丢失,WA
}a[1005];
int cmp(node x,node y)
{
if(x.r<y.r) return 1;//让右端点小的排在前面
else if(x.r==y.r&&x.r<y.r) return 1;
return 0;
}
int main()
{
double x,y,r;
int n,count=1;
while(~scanf("%d %lf",&n,&r))
{
if(n==0&&r==0) return 0;
int flag=0;
for(int i=0;i<n;i++)
{
scanf("%lf %lf",&x,&y);
if(y>r) flag=1;//如果没有方案,即雷达能扫描的半径比它离X轴的距离小,雷达触碰不到
else
{
a[i].l=x-sqrt(r*r-y*y);
a[i].r=x+sqrt(r*r-y*y);
}
}
if(flag==1) printf("Case %d: -1\n",count);
else
{
sort(a,a+n,cmp);
double max=a[0].r;
int ans=1;
for(int i=0;i<n;i++)
{
if(a[i].l>max)
{
ans++;
max=a[i].r;
}
}
printf("Case %d: %d\n",count,ans);
}
count++;
}
return 0;
}