A - Longest Run on a Snowboard

DAG上的动态规划
DAG的定义
DAG意思是有向无环图,所谓有向无环图是指任意一条边有方向,且不存在环路的图。
注:并非是一棵树,边数可以>=n-1

有向无环图示例
A - Longest Run on a Snowboard

容易发现计算每一个点的时候,都要将他的子孙都分别计算一次,这样会大大加大算法的时间复杂度
更容易发现,每当第一次计算完这个点的所有子孙以后,后面的数可以直接用,而不用再去分别计算一下各种点的贡献
所以,可以在计算的过程中,第一次就保留当前点的贡献,并采用数组记录下来,如果下次 再次用到这个点,便可以直接返回当前点的值,而不用继续采用递归的方式计算
新方法:记忆化搜索

例题:
Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift. Michael would like to know how long the longest run in an area is. That area is given by a grid of numbers, defining the heights at those points.
Look at this example:
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-…-3-2-1, it would be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N. Each test case starts with a line containing the name (it’s a single string), the number of rows R and the number of columns C. After that follow R lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than 15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the longest run one can slide down in that area.
Sample Input
2 Feldberg 10 5 56 14 51 58 88 26 94 24 39 41 24 16 8 51 51 76 72 77 43 10 38 50 59 84 81 5 23 37 71 77 96 10 93 53 82 94 15 96 69 9 74 0 62 38 96 37 54 55 82 38 Spiral 5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
Sample Output
Feldberg: 7 Spiral: 25

#include<stdio.h>
#include<bits/stdc++.h>
#define ll long long
#define N 107
using namespace std;
ll h,l,a[N][N]={0};
ll dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
ll dp[N][N];   		//记忆化搜索数组创建
ll dfs(ll x,ll y)
{
 if(dp[x][y])		//如果x,y点已经遍历过,就直接返回DP数组
	  return dp[x][y];
 ll i,j,maxn=0;
 for(i=0;i<4;i++)		//控制上下左右,遍历每一个点
 {
  ll dx,dy;
  dx=x+dir[i][0];dy=y+dir[i][1];
  if(a[x][y]>a[dx][dy]&&dx>=0&&dy>=0&&dx<h&&dy<l)
  {
   maxn=max(maxn,dfs(dx,dy)+1);
  }
 }
 dp[x][y]=maxn;
 return maxn;
}
int main()
{
 memset(a,0,sizeof(a));
 
 ll t;
 cin>>t;
 while(t--)
 {
  ll maxn=0;
  char name[N];
  memset(dp,0,sizeof(dp));
  scanf("%s %d%d",name,&h,&l);
  ll i,j;
  for(i=0;i<h;i++)
   for(j=0;j<l;j++)
    cin>>a[i][j];
    
  for(i=0;i<h;i++)
   for(j=0;j<l;j++)
    {
     if(dp[i][j])			//判断是否遍历过
      maxn=max(maxn,dp[i][j]);
     else
      maxn=max(maxn,dfs(i,j)+1);
    }
    
    
  printf("%s: %d\n",name,maxn);
 }
 
}