PAT-A1099 Build A Binary Search Tree 题目内容及题解
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
题目大意
题目给定一个二叉树和一个数字序列,要求将数字填入数中使其成为一个二叉查找树,并输出其层序遍历。
解题思路
- 读入二叉树和数字序列,并将数字序列排序;
- 中序遍历二叉树并将排好序的数字按照遍历序列填入节点中;
- 用层序遍历按照题目要求的格式输出结果;
- 返回零值。
代码
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 110
struct Node{
int lchild,rchild,data;
}BST[maxn];
int N,num[maxn],seq=0;
void Init(){
int i;
scanf("%d",&N);
for(i=0;i<N;i++){
scanf("%d%d",&BST[i].lchild,&BST[i].rchild);
}
for(i=0;i<N;i++){
scanf("%d",&num[i]);
}
sort(num,num+N);
}
void InOrder(int root){
if(root==-1){
return;
}
InOrder(BST[root].lchild);
BST[root].data=num[seq++];
InOrder(BST[root].rchild);
}
void LayerOrder(){
int Queue[maxn];
int top,front=0,rear=0;
Queue[rear++]=0;
while(rear>front){
top=Queue[front++];
printf("%d",BST[top].data);
N--;
if(N>0){
printf(" ");
}else{
printf("\n");
}
if(BST[top].lchild!=-1){
Queue[rear++]=BST[top].lchild;
}
if(BST[top].rchild!=-1){
Queue[rear++]=BST[top].rchild;
}
}
}
int main(){
Init();
InOrder(0);
LayerOrder();
return 0;
}
运行结果