0-1 背包 Bone Collector hdu-2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 72978    Accepted Submission(s): 30378


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
0-1 背包 Bone Collector hdu-2602

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

15 101 2 3 4 55 4 3 2 1
 

Sample Output

14
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1003 2844

转换式:dp[j]=max(dp[j],dp[j-w]+val)

#include<bits/stdc++.h>
using namespace std;

int c[3500];
int val[3500];
int dp[1000005];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            cin>>c[i];
        }
        for(int i=0; i<n; i++)
        {
            cin>>val[i];
        }
        for(int i=0; i<n; i++)
        {
            for(int j=m; j>=val[i]; j--)//倒序输入
            {
                dp[j]=max(dp[j],dp[j-val[i]]+c[i]);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}