1084 Broken Keyboard (17/20 分)C语言——strchr()
1084 Broken Keyboard (20 分)
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.
Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.
Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _
(representing the space). It is guaranteed that both strings are non-empty.
Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI
分析
<ctype.h>
islower() isupper()判断字母大小写
<string.h>
strchar(str,c)在str中查找c,存在返回第一次找到的位置,不存在返回null
代码
#include<stdio.h>
#include<string.h>
int main(){
char original[85],now[85],set[85];
int i=0,j=0,k,f,top=0;
scanf("%s\n%s",original,now);
while(original[i]){
if(now[j]!=original[i]){
f=original[i];
f=(f>=97 ? f-32 : f);
if(!strchr(set,f))
set[top++]=f;
}else j++;
i++;
}
printf("%s",set);
}
没有满分 17/20 (哪里有错望指出)