【UVA】 232 --- Crossword Answers

【UVA】 232 --- Crossword Answers


A crossword puzzle consists of a rectangular grid of black and
white squares and two lists of definitions (or descriptions).
One list of definitions is for “words” to be written left to
right across white squares in the rows and the other list is for
words to be written down white squares in the columns. (A
word is a sequence of alphabetic characters.)
To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.
The definitions correspond to the rectangular grid by
means of sequential integers on “eligible” white squares.
White squares with black squares immediately to the left or
above them are “eligible.” White squares with no squares either immediately to the left or above are also “eligible.” No other squares are numbered. All of the
squares on the first row are numbered.
The numbering starts with 1 and continues consecutively across white squares of the first row, then
across the eligible white squares of the second row, then across the eligible white squares of the third
row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular
crossword puzzle grid with appropriate numbering.
An “across” word for a definition is written on a sequence of white squares in a row starting on a
numbered square that does not follow another white square in the same row.
The sequence of white squares for that word goes across the row of the numbered square, ending
immediately before the next black square in the row or in the rightmost square of the row.
A “down” word for a definition is written on a sequence of white squares in a column starting on a
numbered square that does not follow another white square in the same column.
The sequence of white squares for that word goes down the column of the numbered square, ending
immediately before the next black square in the column or in the bottom square of the column.
Every white square in a correctly solved puzzle contains a letter.
You must write a program that takes several solved crossword puzzles as input and outputs the lists
of across and down words which constitute the solutions.
Input
Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and
1 ≤ c ≤ 10), where r (the first number) is the number of rows in the puzzle and c (the second number)
is the number of columns.
The r rows of input which follow each contain c characters (excluding the end-of-line) which describe
the solution. Each of those c characters is an alphabetic character which is part of a word or the
character ‘’, which indicates a black square.
The end of input is indicated by a line consisting of the single number ‘0’.
Output
Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the
list of across words followed by the list of down words. Words in each list must be output one-per-line
in increasing order of the number of their corresponding definitions.
The heading for the list of across words is ‘Across’. The heading for the list of down words is ‘Down’.
In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’
headings should still appear.
Separate output for successive input puzzles by a blank line.
Sample Input
2 2
AT
O
6 7
AIM
DEN
MEONE
UPON
TO
SOERIN
SAOR

IES*DEA
0
Sample Output
puzzle #1:
Across
1.AT
3.O
Down
1.A
2.TO
puzzle #2:
Across
1.AIM
4.DEN
7.ME
8.ONE
9.UPON
11.TO
12.SO
13.ERIN
15.SA
17.OR
18.IES
19.DEA
Down
1.A
2.IMPOSE
3.MEO
4.DO
5.ENTIRE
6.NEON
9.US
10.NE
14.ROD
16.AS
18.I
20.A

题意:
输入一个r行c列( 1≤r, c≤10) 的网格, 黑格用“*”表示, 每个白格都填有一个字母。 如
果一个白格的左边相邻位置或者上边相邻位置没有白格( 可能是黑格, 也可能出了网格边
界) , 则称这个白格是一个起始格。
首先把所有起始格按照从上到下、 从左到右的顺序编号为1, 2, 3,…,
【UVA】 232 --- Crossword Answers
如图r行c列网格接下来要找出所有横向单词( Across) 。 这些单词必须从一个起始格开始, 向右延伸到
一个黑格的左边或者整个网格的最右列。 最后找出所有竖向单词( Down) 。 这些单词必须
从一个起始格开始, 向下延伸到一个黑格的上边或者整个网格的最下行。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
int Across(int i, int j, int c);
int Down(int i, int j, int r);
using namespace std;
int arr[11][11]{ 0 };
char str[11][11];
int main()
{
	int count = 0;
	while (true)
	{
		int r, c, num = 0;
		cin >> r;
		if (r == 0)
		{
			return 0;
		}
		cin >> c;
		getchar();
		for (int i = 0; i < r; i++)
		{
			for (int j = 0; j < c; j++)
			{
				scanf("%c", &str[i][j]); // 输入方格
				if ((i == 0 || j == 0) && str[i][j] != '*') //标记起始格
				{
					arr[i][j] = ++num;
				}
				else if ((str[i - 1][j] == '*' || str[i][j - 1] == '*') && str[i][j] != '*')
				{
					arr[i][j] = ++num;
				}
			}
			getchar();
		}
		if (count)
		{
			cout << endl;
		}
		cout << "puzzle #" << ++count << ":" << endl;
		cout << "Across" << endl;
		for (int i = 0; i < r; i++)
		{
			for (int j = 0; j < c; j++)
			{
				j = Across(i, j, c);
			}
		}
		cout << "Down" << endl;
		for (int i = 0; i < r; i++)
		{
			for (int j = 0; j < c; j++)
			{
				Down(i, j, r);
			}
		}
	}
	return 0;
}

int Across(int i, int j, int c)
{
	if (arr[i][j] != 0)
	{
		printf("%3d.", arr[i][j]);
		for (; j < c; j++)
		{
			if (str[i][j] == '*')
			{
				cout << endl;
				return j;
			}
			else
			{
				cout << str[i][j];
			}
		}
		cout << endl;
	}
	return j;
}

int Down(int i, int j, int r)
{
	if (arr[i][j] != 0)
	{
		printf("%3d.", arr[i][j]);
		for (; i < r; i++)
		{
			if (str[i][j] == '*')
			{
				cout << endl;
				return 0;
			}
			else
			{
				cout << str[i][j];
			}
			arr[i][j] = 0;
		}
		cout << endl;
	}
	return 0;
}