【UVA】 11809 --- Floating-Point Numbers

【UVA】 1588 --- Kickdown


Floating-point numbers are represented differently in computers than integers. That is why a 32-bit
floating-point number can represent values in the magnitude of 1038 while a 32-bit integer can only
represent values as high as 232
.
Although there are variations in the ways floating-point numbers are stored in Computers, in this
problem we will assume that floating-point numbers are stored in the following way:
【UVA】 11809 ---	Floating-Point Numbers
Floating-point numbers have two parts mantissa and exponent. M-bits are allotted for mantissa
and E bits are allotted for exponent. There is also one bit that denotes the sign of number (If this
bit is 0 then the number is positive and if it is 1 then the number is negative) and another bit that
denotes the sign of exponent (If this bit is 0 then exponent is positive otherwise negative). The value of
mantissa and exponent together make the value of the floating-point number. If the value of mantissa
is m then it maintains the constraints 1
2 ≤ m < 1. The left most digit of mantissa must always be 1 to
maintain the constraint 1
2 ≤ m < 1. So this bit is not stored as it is always 1. So the bits in mantissa
actually denote the digits at the right side of decimal point of a binary number (Excluding the digit
just to the right of decimal point)
In the figure above we can see a floating-point number where M = 8 and E = 6. The largest value
this floating-point number can represent is (in binary) 0.1111111112 ×2
1111112
. The decimal equivalent
to this number is: 0.998046875 × 2
63 = 920535763834529382410. Given the maximum possible value
represented by a certain floating point type, you will have to find how many bits are allotted for
mantissa (M) and how many bits are allotted for exponent (E) in that certain type.

Input
The input file contains around 300 line of input. Each line contains a floating-point number F that
denotes the maximum value that can be represented by a certain floating-point type. The floating point
number is expressed in decimal exponent format. So a number AeB actually denotes the value A×10B.
A line containing ‘0e0’ terminates input. The value of A will satisfy the constraint 0 < A < 10 and
will have exactly 15 digits after the decimal point.

Output
For each line of input produce one line of output. This line contains the value of M and E. You can
assume that each of the inputs (except the last one) has a possible and unique solution. You can also
assume that inputs will be such that the value of M and E will follow the constraints: 9 ≥ M ≥ 0 and
30 ≥ E ≥ 1. Also there is no need to assume that (M + E + 2) will be a multiple of 8.

Sample Input
5.699141892149156e76
9.205357638345294e18
0e0

Sample Output
5 8
8 6

题意:
【UVA】 11809 ---	Floating-Point Numbers
思路:
通过打表将ME范围所对应的最大浮点数全部算出,然后再一一对照。

AC代码:

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
	long long arr_e[10][35];
	double arr_m[10][35];
	double m;
	long long e;
	for (int i = 0; i <= 9; i++)  // 打表
	{
		for (int j = 1; j <= 30; j++)
		{
			m = 1 - pow(2, -1 - i); //用m存储以i为尾数,j为阶码的最大浮点数的尾数部分的十进制
			e = pow(2, j) - 1;  //用e存储以i为尾数,j为阶码的最大浮点数的阶码的十进制
			double x = log10(m) + e * log10(2);  //用x存储该最大浮点数所对应的十的多少次方
			arr_e[i][j] = x / 1; //用arr_e[i][j]存储A*10^B中的B;
			arr_m[i][j] = pow(10, x - arr_e[i][j]); //用arr_m[i][j]存储A*10^B中的A;
		}
	}
	char arr[25];
	while (cin >> arr)
	{
		if (!strcmp(arr, "0e0"))
		{
			return 0;
		}
		int len = strlen(arr);
		for (int i = 0; i < len; i++)
		{
			if (arr[i] == 'e')
			{
				arr[i] = ' ';
				break;
			}
		}
		sscanf_s(arr, "%lf %lld", &m, &e); //将小数部分和指数部分分别赋值给m,e
		bool flag = true;
		for (int i = 0; i < 10; i++)
		{
			for (int j = 0; j <= 30; j++)
			{
				if (e == arr_e[i][j] && fabs(m - arr_m[i][j]) <1e-5) 
				{
					cout << i << " " << j << endl;
					flag = false;
					break;
				}
			}
			if (!flag) break;
		}
	}
	return 0;
}