PAT-A1118 Birds in Forest 题目内容及题解
Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10^4.
After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.
Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
题目大意
题目给出一组鸟的照片,假设所有出现在同一幅图中的鸟都属于同一棵树。题目要求输出森林中最大的树木数量和鸟的数量;另外提出一组请求序列,要求对请求序列中的任何一对鸟判断它们是否在同一棵树上。
解题思路
- 初始化并查集信息;
- 读取数据并加入并查集,同时记录最大鸟数;
- 判断最大的树的数目(并查集数);
- 判断每对鸟是否在同个并查集中并输出结果;
- 返回零值。
代码
#include<stdio.h>
#define maxn 10010
int father[maxn],vis[maxn],isRoot[maxn];
int N,Q,cnt;
int FindFather(int x){
int z=x,a;
while(x!=father[x]){
x=father[x];
}
while(z!=x){
a=z;
z=father[z];
father[a]=x;
}
return x;
}
void Union(int a,int b){
int faA=FindFather(a);
int faB=FindFather(b);
if(faA!=faB){
father[faB]=faA;
}
}
void Check(int a,int b){
int faA=FindFather(a);
int faB=FindFather(b);
if(faA!=faB){
printf("No\n");
}else{
printf("Yes\n");
}
}
int main(){
int k,a,b;
int i=0;
scanf("%d",&N);
for(i=1;i<10000;i++){
father[i]=i;
}
while(N--){
scanf("%d",&k);
k--;
scanf("%d",&a);
vis[a]=1;
while(k--){
scanf("%d",&b);
vis[b]=1;
Union(a,b);
}
}
N=1;
while(vis[N]){
k=FindFather(N);
isRoot[k]=1;
N++;
}
for(i=1;i<N;i++){
cnt+=isRoot[i];
}
printf("%d %d\n",cnt,N-1);
scanf("%d",&Q);
while(Q--){
scanf("%d%d",&a,&b);
Check(a,b);
}
return 0;
}
运行结果