1580-闰年-JAVA

闰年

Time Limit: 1000 ms Memory Limit: 32768 KiB


 

Problem Description

时间过得真快啊,又要过年了,同时,我们的人生也增长了一年的阅历,又成熟了一些。可是,你注意过今年是不是闰年呢,明年呢?

1580-闰年-JAVA

以上是闰年的计算方法的流程图,聪明的你能否通过编程计算任意给出的一个年份是否是闰年呢?相信这个问题你能很快解决掉。


 

Input

只有一个整数year,代表年份。

Output

如果是闰年输出Yes,否则输出No。


Sample Input

2000

Sample Output

Yes

Hint


Source

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int year = scanner.nextInt();
			if (year % 4 == 0 && year % 100 != 0 || year % 400 == 0) {
				System.out.println("Yes");
			} else {
				System.out.println("No");
			}
		}
	}
}