HDU 2602 Bone Collector(01背包)

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone

  

 

Output  

One integer per line representing the maximum of the total value (this number will be less than 2 31).

 

Sample Input 

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output  

14

 

 

题意:

 

一个叫做Bone Collector的男的有一个包,往包里放东西,使得其价值最大。

输入:注意是先输入的是价值,后是体积。

 

思路:

单纯的01背包

 

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include<cmath>
#include<algorithm>
#define max(a,b) a>b?a:b
using namespace std;
int main()
{
    int T,N,V,f[1001],vol[1001],val[1001] ,tem;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&N,&V);
        for(int i = 1 ; i <= N ; i++)
        scanf("%d",&val[i]);
        for(int i = 1 ; i <= N ; i++)
        scanf("%d",&vol[i]);
        memset(f,0,sizeof(f));
        for(int i = 1 ; i<=N;i++)
        {
            for(int j = V ; j >= vol[i]; j--)
            {
               f[j]=max(f[j],f[j-vol[i]]+val[i]);
              
            }
        }
        cout<<f[V]<<endl;
    }
    return 0;
}

 

 

 

 动态调试运行情况:

HDU 2602 Bone Collector(01背包)