PAT-A1060 Are They Equal 题目内容及题解

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题目大意

题目给定机器上的有效数字和两个浮点数的数量,要求输出两个数字在给定的有效数字下存储结果是否一致。截断数字时只需要简单截断,无需四舍五入。

解题思路

  1. 用字符串形式读入两组待对比数据,并将其处理为目标形式;
  2. 对比其是否一致,并按照格式输出结果;
  3. 返回零值。

代码

#include<iostream>
#include<string>
using namespace std;
int N,e;

string Deal(string a){
    int k=0;
    int num=0;
    string res;
    e=0;
    while(a.length()>0&&a[0]=='0'){
        a.erase(a.begin());
    }
    if(a[0]=='.'){
        a.erase(a.begin());
        while(a.length()>0&&a[0]=='0'){
            a.erase(a.begin());
            e--;
        }
    }else{
        while(k<a.length()&&a[k]!='.'){
            k++;
            e++;
        }
        if(k<a.length()){
            a.erase(a.begin()+k);
        }
    }
    if(a.length()==0){
        e=0;
    }
    while(num<N){
        if(num<a.length()){
            res+=a[num];
        }else{
            res+='0';
        }
        num++;
    }
    return res;
}


int main(){
    string A,B;
    int e1;
    cin>>N>>A>>B;
    A=Deal(A);
    e1=e;
    B=Deal(B);
    if(A==B&&e1==e){
        cout<<"YES 0."<<A<<"*10^"<<e<<endl;
    }else{
        cout<<"NO 0."<<A<<"*10^"<<e1<<" 0."<<B<<"*10^"<<e<<endl;
    }
    return 0;
}

运行结果

PAT-A1060 Are They Equal 题目内容及题解