PAT-A1002 A+B for Polynomials 题目内容及题解

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意

题目给出A和B两个多项式,求出其和多项式并按照规定格式输出。

解题思路

  1. 读入第一个多项式,并时刻保持记录当前最大的指数;
  2. 依次读入第二个多项式,并根据其内容做出修正(需注意double判别相等不能直接使用‘==’);
  3. 按照题目要求从大到小输出多项式并返回零值。

代码

#include<stdio.h>
#include<math.h>
#define maxn 1010
#define err 1E-7
int main(){
    double a[maxn]={0.0};
    int num=0,max=0;//max记录当前最大的指数值
    int k,i,exp;
    double coe;
    scanf("%d",&k);
    num=k;
    for(i=0;i<k;i++){
        scanf("%d%lf",&exp,&coe);
        a[exp]=coe;
        max=(exp>max?exp:max);
    }
    scanf("%d",&k);
    for(i=0;i<k;i++){
        scanf("%d%lf",&exp,&coe);
        if(fabs(a[exp])<err){
            max=(exp>max?exp:max);
            num++; 
        }
        a[exp]=a[exp]+coe;
        if(fabs(a[exp])<err){
            num--;
        }
    }
    printf("%d",num);
    while(max>=0){
        if(fabs(a[max])>=err){
            printf(" %d %.1f",max,a[max]);
            num--;
        }
        if(num<=0){
            break;
        }
        max--;
    }
    printf("\n");
    return 0;
}

运行结果

PAT-A1002 A+B for Polynomials 题目内容及题解