C# 闰年

闰年

Time Limit: 1000 ms Memory Limit: 32768 KiB

Problem Description

时间过得真快啊,又要过年了,同时,我们的人生也增长了一年的阅历,又成熟了一些。可是,你注意过今年是不是闰年呢,明年呢?

C# 闰年

以上是闰年的计算方法的流程图,聪明的你能否通过编程计算任意给出的一个年份是否是闰年呢?相信这个问题你能很快解决掉。

 

Input

只有一个整数year,代表年份

Output

如果是闰年输出Yes,否则输出No

Sample Input

2000

Sample Output

Yes

Hint


Source



using System;
using System.Collections.Generic;
using System.Linq;
namespace ConsoleApp1{
    class Program{
        static void Main(){
            jdg(int.Parse(Console.ReadLine()));
            Console.ReadKey();
        }
        static void jdg(int a) {
            if((a % 4 == 0 && a % 100 != 0) || a % 400 == 0) {
                Console.Write("Yes");
            }
            else {
                Console.Write("No");
            }
        }
    }
}


/***************************************************
User name: QwQ。。。
Result: Accepted
Take time: 52ms
Take Memory: 4996KB
Submit time: 2018-02-17 21:58:56
****************************************************/