LightOJ 1282 Leading and Trailing 【快速幂+数学】

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

思路:求后三位比较好求,用快速幂可以求出来,而前三位比较巧妙,膜大神。

其中abc就是要求的前三位。

LightOJ 1282 Leading and Trailing 【快速幂+数学】

#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 + 10;

int powermod(int a, int b, int c)
{
    int ans = 1;
    a %= c;
    while(b)
    {
        if(b & 1)
            ans = ans * a % c;
        b >>= 1;
        a = a * a % c;
    }
    return ans % c;
}

int main()
{
    int t;
    scanf("%d", &t);
    for(int i = 1; i <= t; ++i)
    {
        int n, k;
        scanf("%d%d", &n, &k);
        double m = k * log10(n) - (int)(k * log10(n));
        int x = pow(10, m) * 100;
        int y = powermod(n, k, 1000);
        printf("Case %d: %d %03d\n", i, x, y);
    }
    return 0;
}