1146 Topological Order (25 分)
1146 Topological Order (25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;
struct node
{
int in=0;//入度
vector<int> out;//出度
};
int main()
{
int n,m;
scanf("%d%d",&n,&m);
vector<node> nodes(n+1);
int a,b;
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
nodes[a].out.push_back(b);//插入点b到out数组中
nodes[b].in++;
}
int query;
scanf("%d",&query);
int cnt=0;
for(int i=0;i<query;i++)
{
bool flag=true;
vector<node> tNodes(nodes);//拷贝nodes到tNodes
for(int j=0;j<n;j++)
{
int t;
scanf("%d",&t);
if(!flag) continue;
if(tNodes[t].in==0)
{
for(int k=0;k<tNodes[t].out.size();k++)
{
tNodes[tNodes[t].out[k]].in--;
}
}
else{
if(cnt!=0) printf(" ");
printf("%d",i);
cnt++;
flag=false;
}
}
}
return 0;
}