1146 Topological Order (25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
C++:
/*
@Date : 2018-08-08 20:54:44
@Author : 酸饺子 ([email protected])
@Link : https://github.com/SourDumplings
@Version : $Id$
*/
/*
https://pintia.cn/problem-sets/994805342720868352/problems/994805343043829760
*/
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
const int MAXN = 1005;
int N, M;
bool G[MAXN][MAXN];
vector<int> indegree(MAXN);
int main(int argc, char const *argv[])
{
for (int i = 0; i < MAXN; ++i)
{
for (int j = 0; j < MAXN; ++j)
{
G[i][j] = false;
}
indegree[i] = 0;
}
scanf("%d %d", &N, &M);
for (int i = 0; i < M; ++i)
{
int v, w;
scanf("%d %d", &v, &w);
G[v][w] = true;
++indegree[w];
}
int K;
vector<int> ret;
scanf("%d", &K);
for (int i = 0; i < K; ++i)
{
bool top = true;
vector<int> tempIndegree(indegree);
for (int j = 0; j < N; ++j)
{
int v;
scanf("%d", &v);
if (top)
{
if (tempIndegree[v] == 0)
{
for (int k = 1; k <= N; ++k)
{
if (G[v][k])
{
--tempIndegree[k];
}
}
}
else
top = false;
}
}
if (!top)
{
ret.push_back(i);
}
}
int output = 0;
for (auto &i : ret)
{
if (output++)
{
putchar(' ');
}
printf("%d", i);
}
putchar('\n');
return 0;
}