1146 Topological Order (25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
最后一个点会超时,此题代码仅供参考。
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
using namespace std;
int n, m, k;
int graph[1010][1010], tmp[1010][1010];
int main() {
cin >> n >> m;
for (int i = 1; i <= m; i++) {
int v1, v2;
scanf("%d%d", &v1, &v2);
graph[v1][v2] = 1;
tmp[v1][v2] = 1;
}
cin >> k;
vector<int> ans;
for (int i = 0; i < k; i++) {
vector<int> qy(n);
for (int j = 1; j <= n; j++) {
for (int u = 1; u <= n; u++) {
graph[j][u] = tmp[j][u];
}
}
bool isout = 0;
for (int j = 0; j < n; j++) {
scanf("%d", &qy[j]);
bool flag = 0;
for (int u = 1; u <= n; u++) {
if (graph[u][qy[j]] == 1) {
flag = 1;
if (isout == 0) {
ans.push_back(i);
isout = 1;
}
break;
}
}
if (flag == 0) {
for (int u = 1; u <= n; u++) {
if (graph[qy[j]][u] == 1) graph[qy[j]][u] = 0;
}
}
}
}
for (int i = 0; i < (int)ans.size(); i++) {
if (i == 0) printf("%d", ans[i]);
else printf(" %d", ans[i]);
}
return 0;
}