闰年

闰年

Time Limit: 1000 ms Memory Limit: 32768 KiB

Submit Statistic Discuss

Problem Description

时间过得真快啊,又要过年了,同时,我们的人生也增长了一年的阅历,又成熟了一些。可是,你注意过今年是不是闰年呢,明年呢?

闰年

以上是闰年的计算方法的流程图,聪明的你能否通过编程计算任意给出的一个年份是否是闰年呢?相信这个问题你能很快解决掉。

 

Input

只有一个整数year,代表年份。

Output

如果是闰年输出Yes,否则输出No。

Sample Input

2000

Sample Output

Yes

Hint

 

Source

2011软件1-5班《程序设计基础》机试 tongjiantao

#include<stdio.h>

int main()
{ 
	int y  ;
	scanf("%d", &y);
	if (y % 4 == 0) {
		if (y % 100 != 0) {//能被4整除但不能被100整除的普通闰年
			printf("Yes\n");
		}
		else {
			if (y % 400 == 0)//能被400整除的世纪闰年
				printf("Yes\n");
			else printf("No\n");
		}
	  }
	else printf("No\n");
	return 0;
}